Serveradministration - Forum

Derzeit sind Sie als Gast in unserem Forum aktiv. Für das Schreiben registrieren Sie sich bitte. Unser Forum ist eine Austauschplattform für Webworker zum Kommunizieren, Helfen, Informieren und Hilfe finden. Auf der rechten Seiten finden Sie eine Forenübersicht über alle Bereiche des Webmaster-Forums. Unterhalb finden Sie alle aktuellen Themen.


Patrick Schwering
Beiträge: 86

PN schreiben
Profil ansehen
User ist offline

Linux, Apache2 - Weiterleitungs Problem

Link zur Antwort auf "Linux, Apache2 - Weiterleitungs Problem" von Patrick Schwering Patrick Schwering, am Freitag den 20.05.2011 um 15:59:56

Moin,
derzeit sitze ich vor einem sehr komischen Problem.
Ich versuch es mal mit einem kleinen Beispiel zu erklären:

In meinem ispCP Interface habe ich einen komplett neuen Webspace angelegt, das /htdocs Verzeichnis besitzt nur die index.php

Ruf ich jetzt http://www.domain.de/index.php auf wird diese wunderbar angezeigt.
Ruf ich folgende URLs auf, erwarte ich einen 404 Fehler:

http://www.domain.de/index
http://www.domain.de/index/lalala

Diesen bekomm ich aber nicht ... Der Server liefert mir die index.php zurück.

Wenn ich http://www.domain.de/lala.php aufrufe erhalte ich wie gewollt meine 404 Seite.
Ruf ich z.B. http://www.domain.de/lala auf erhalte ich ebenfalls meine 404 Seite, leg ich jetzt eine lala.php an und ruf wieder http://www.domain.de/lala auf, bekomm ich den Inhalt meiner lala.php angezeigt.

Kann mir hier evtl. jemand bei meinem Problem helfen?
Ich habe leider keine Ahnung wo ich dort auf dem Server eingreifen muss.

MfG.

Patrick

EDIT:
Kurzer Nachtrag, ich kann dies mit allen Dateien auf dem Webspace durchführen.
Beispiel:
http://www.domain.de/css/style ruft die vorhandene http://www.domain.de/css/style.css auf.
Da ist doch irgendwas falsche :(

Insgesamt 1 mal bearbeitet, zuletzt am 22.05.2011 um 14:46:53

Patrick Schwering
Beiträge: 86

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Linux, Apache2 - Weiterleitungs Problem" von Patrick Schwering Patrick Schwering, am Sonntag den 22.05.2011 um 19:59:20

Ich nochmal, hab die Lösung jetzt selber gefunden :)

Falls wer das selbe Problem haben sollte:

Options Indexes MultiViews ExecCGI

Das MultiView war aktiviert, einfach entfernen und fertig.