Betriebssysteme (Windows, Linux, etc.) - Forum

Derzeit sind Sie als Gast in unserem Forum aktiv. Für das Schreiben registrieren Sie sich bitte. Unser Forum ist eine Austauschplattform für Webworker zum Kommunizieren, Helfen, Informieren und Hilfe finden. Auf der rechten Seiten finden Sie eine Forenübersicht über alle Bereiche des Webmaster-Forums. Unterhalb finden Sie alle aktuellen Themen.


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline

Xampp Port 80 Problem

Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Samstag den 01.10.2011 um 21:56:09

Hallo,

hatte auf meinem PC immer Xampp installiert, habe den PC platt gemacht und habe es neu installieren.

Als ich dann Apache starten wollte kam

 
Text
1
2
Busy...
Apache startet [Port 80]

MySql läuft.

\xampp\apache\logs ist leer.

Skype ist nicht installiert, Xampp neu installiert hab ich schon.

Hat da jemand eine Idee für mich?

Danke,

Fabian

Link zur Antwort auf "Xampp Port 80 Problem" von Jannik Zschiesche Jannik Zschiesche, am Montag den 03.10.2011 um 03:02:58

Fehlermeldung? Localhost nicht erreichbar oder wie? Betriebssystem?


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Montag den 03.10.2011 um 18:19:42

Wie? ich kann Apache gar nicht starten. Da steht einfach nicht "Running". Also ich kanns nicht Starten.

MySQL läuft ohne Probleme, was mir da ja leider wenig bringt :/


Benutzer gelöscht
Beiträge: 166

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Benutzer gelöscht Benutzer gelöscht, am Montag den 03.10.2011 um 20:36:39
Zitat von: Ahnungsloser

ich kann Apache gar nicht starten.

Und was steht im errorlog?


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Dienstag den 04.10.2011 um 09:06:44

Wie gesagt... gibt's nicht!

\xampp\apache\logs ist leer.


Moritz Kern
Beiträge: 1678

PN schreiben
Profil ansehen
Homepage besuchen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Moritz Kern Moritz Kern, am Dienstag den 04.10.2011 um 10:31:56
Zitat von: Jannik Zschiesche

Betriebssystem?

wär tatsächlich noch interessant (unter Vista gibt es bsw. oft Probleme mit der Benutzerkontensteuerung -> deaktivieren)


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Dienstag den 04.10.2011 um 12:28:33

upps. vergessen zu schreiben :D

Windows 7

Link zur Antwort auf "Xampp Port 80 Problem" von Jannik Zschiesche Jannik Zschiesche, am Dienstag den 04.10.2011 um 13:36:08

Als Service installieren (ist das nicht sowieso unter Win empfohlen?)

Mal als Admin ausgeführt?


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Dienstag den 04.10.2011 um 14:49:34

Als Admin bringt nix.

Als Service ne... aber vorher ging's ja auch so...


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Dienstag den 04.10.2011 um 15:55:03

Hallo,

danke erstmal für die Hilfe!

Es läuft jetzt. keine Ahnung warum 0.o


Roman Martin
Beiträge: 14

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Roman Martin Roman Martin, am Samstag den 08.10.2011 um 12:27:01

Benutzt du zufällig Skype? :)

Apache lässt sich nicht staren wenn Skype (in der Standardkonfiguration) parallel läuft.


weaZel
Beiträge: 116

PN schreiben
Profil ansehen
Homepage besuchen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von weaZel weaZel, am Sonntag den 09.10.2011 um 12:52:20

Wir hatten das Problem bei uns auch und wir hatten auf einigen Rechnern das Problem das Skype nicht die Ursache des Problems war.

Was uns dann schließlich aber geholfen hat war folgender Blogpost:

Getting Apache to run on port 80 on Windows 7

by Cameron on January 25, 2009

Running the command ‘netstat -ano’ from the command line revealed

that port 80 is being used by PID 4.

Looking up PID 4 using Power Shell and then Task Manager revealed
that PID 4 is the NT Kernel!

So Windows 7 by default appears to be using port 80.

After a bit of hunting around the Internet and doing some research of my own I found that the service http.sys was the culprit and all I needed to do was disable it but I could not find this service listed in the Services control panel applet.

So what’s the solution?

You have to disable the http.sys service manually via the registry:

1) Launch RegEdit:

2) Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP

3) Add a new DWORD (32-bit) value

4) Name it ‘NoRun’ not including the quotes

5) Double click the new property

6) In the Value data field type ’1′ not including quotes and click OK

7) Re-boot your computer

You should now find that Apache will start on port 80!


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Sonntag den 09.10.2011 um 19:50:55

danke Leute,

ich würd's ja gerne ausprobieren aber es klappt auch so :)

DANKE!


Ahnungsloser
Beiträge: 211

PN schreiben
Profil ansehen
User ist offline
Link zur Antwort auf "Xampp Port 80 Problem" von Ahnungsloser Ahnungsloser, am Donnerstag den 27.10.2011 um 16:20:12

Hallo,

so als Nachtrag:

Ich vermute das es am Spiel League of Legents lag.